SR 2.1.0 and PHP 4 Issues

There are a few issues in PHP 4 which will causes errors such as:
Parse error: syntax error, unexpected T_OBJECT_OPERATOR in
I am working on a fix at the moment. PHP 5 is fine.